Hallo, Gast
Du musst dich registrieren bevor du auf unserer Seite Beiträge schreiben kannst.

Benutzername/E-Mail:
  

Passwort
  





Durchsuche Foren

(Erweiterte Suche)

Foren-Statistiken
» Mitglieder: 385
» Neuestes Mitglied: Xollen
» Foren-Themen: 524
» Foren-Beiträge: 7.404

Komplettstatistiken

Aktive Themen
Hi all, small question
Forum: BMWRaspControl - english questions
Letzter Beitrag: Xollen
Vor 9 Stunden
» Antworten: 25
» Ansichten: 1.450
[Bug] Nächster Titel über...
Forum: IBusCommunicator - Allgemein
Letzter Beitrag: harryberlin
Gestern, 00:25
» Antworten: 8
» Ansichten: 336
PDC aktivieren unter xx k...
Forum: IBusCommunicator - Allgemein
Letzter Beitrag: harryberlin
15.11.2017, 23:41
» Antworten: 18
» Ansichten: 333
PiBUS Interface Board
Forum: BMWRaspControl - Hardware
Letzter Beitrag: harryberlin
09.11.2017, 21:12
» Antworten: 91
» Ansichten: 3.148
[Image] OSMC mit IBus Ver...
Forum: IBusCommunicator - Allgemein
Letzter Beitrag: Kev
08.11.2017, 22:16
» Antworten: 187
» Ansichten: 32.370
ZV entriegeln bei Schlüss...
Forum: IBusCommunicator - Allgemein
Letzter Beitrag: harryberlin
08.11.2017, 21:55
» Antworten: 1
» Ansichten: 74
BMW E39 Einbau ohne Board...
Forum: BMW E39
Letzter Beitrag: xboxcristal
06.11.2017, 23:37
» Antworten: 10
» Ansichten: 1.774
BMW e46 KI & BC Außentemp...
Forum: Allgemeine Themen / News
Letzter Beitrag: Andy_90
05.11.2017, 17:03
» Antworten: 11
» Ansichten: 310
Einbau im Videomodul
Forum: BMW E38
Letzter Beitrag: harryberlin
26.10.2017, 20:15
» Antworten: 2
» Ansichten: 122
Hardware minimum
Forum: BMWRaspControl - english questions
Letzter Beitrag: harryberlin
23.10.2017, 19:14
» Antworten: 1
» Ansichten: 151

 
  Kodi 17.3 / Android
Geschrieben von: Raceface - 18.07.2017, 01:34 - Forum: IBusCommunicator - Allgemein - Antworten (3)

Hallo, 
ich hatte heute mal Kodi 17.3 auf meinem Android Handy installiert und habe versucht den IbusCommunicator zum laufen zu bringen.
Da die Installation nicht geklappt hat habe ich es mit dem DSA addon probiert was auf Anhieb funktioniert hat, die Installation des Skins war ebenfalls möglich. 

Ist es mit sehr viel Aufwand verbunden den IbusCommunicator auf Kodi unter Android laufen zu lassen, auf dem Raspberry Pi ?
Dann könnte man ja theoretisch den Pi mit einem OBD Stecker mit Carly verbinden und hätte die Möglichkeit an alle live Daten zu kommen, zu codieren, den Fehlerspeicher zu lesen usw.
Da Kodi dann auf die Android Apps zugreifen kann hätte man einen funktionierenden Internet Browser und weitere Apps .

Huh
MfG

Drucke diesen Beitrag

Music KeyMemory-Playlist
Geschrieben von: schmucki - 17.07.2017, 08:45 - Forum: IBusCommunicator - Allgemein - Antworten (3)

Hallöchen,

wäre es nicht klasse, wenn es die Möglichkeit gäbe, schlüsselspezifische Wiedergabe einzubinden?
Evtl. über ReliableResume? Wenn ich bspw. zwei Ordner auf meinem USB-Stick habe (Musik_Mann und Musik_Frau) und Kodi fängt autom. an aus dem Ordner zu spielen, der als letztes mit dem aktuellen Schlüssel abgespielt wurde? Eine Abfrage, welcher Schlüssel eingesteckt ist, ist ja bereits vorhanden.
Grüße und Danke

Drucke diesen Beitrag

  Problem mit USB Stick
Geschrieben von: cgr - 16.07.2017, 13:34 - Forum: BMWRaspControl - Kodi / Skin - Antworten (6)

Moin zusammen, 

ich habe ein seltsames Phänomen: 

Ich habe eine USB-Hub Spinne am RasP2B. Dort steckt mein USB Stick mit Musik-Daten drin (Sandisk 64GB glaube ich). Sobald ich nun einen zweiten USB Stick einstecke (und zwar einen ganz bestimmten, bei anderen ist das Verhalten nicht so), spinnt der RasPi rum. Er stürzt sofort ab, oder springt nach 3 Sekunden auf das Radio um, oder ist nicht mehr bedienbar, oder oder. 

Habt Ihr eine Idee, woran das leigen kann?

Am USB Stick (Geschwindigkeit (ist USB3.0), Stromverbrauch, Formatierung, Größe, ...)?
Oder am USB Hub?
Oder ist das ein SW Bug (Kodi, IBUSCommunicator, ...)?
Oder ...?

Wie kann ich hier weiter forschen?




Viele Grüße

cgr

Drucke diesen Beitrag

  History / PreiousLocation verfügbar?
Geschrieben von: cgr - 16.07.2017, 13:30 - Forum: BMWRaspControl - Kodi / Skin - Keine Antworten

Moin zusammen,

eine kurze Feage zum Kodi / OSMC: 

Gibt es beim Music-Player eigentlcihso etwas wire eine "History" oder eine "Previous File" Funktion?

Die frage kommt, weil ich folgendes "Problemchen" habe: Sagen wir einmal, morgens fährt man los und möchte nur leicht Dudelmusik vom USB Stick hören, abends auf der Rückfahrt dann aber Rockmusik um den Tages-Ärger zu verarbeiten. Kann man dann, wenn man am nächsten morgen wieder losfährt, einfach wieder zu der vorherigen Dati-Position finden und auf die Musik/Datei/Dateipfad umspringen, die man am Tag vorher VOR der Rockmusik gehört hat?


Momentan fange ich immer wieder bei null an und hangele mich von der letzten Musik (eben z.B. Rock) wieder auf den alten Dateipfad hoch, der die Dudelmusik enthält.


Viele Grüße

cgr

Drucke diesen Beitrag

  Senderwahl UKW nach Neustart
Geschrieben von: cgr - 16.07.2017, 13:24 - Forum: IBusCommunicator - Allgemein - Antworten (2)

Moin zusammen,

ich habe teilweise ein etwas seltsames Verhalten in meinem Radio (e85, BNW professional mit Navi):

Sobald der Raspi aus ist und das Radio noch an ist, schaltet das Radio auf UKW um. So ist das ja auch, wenn man eine CD hört und diese dann auswirft - das Radio geht auf UKW mit dem letzten gehörten Sender. Meistens, wenn der Raspi neu startet (weil abgestürzt), schaltet das Radio dann zwar auf die UKW Quelle, aber nciht auf den letzten, eingestellten Sender. 

Also in anderen Worten: Auto fahrten, Radio auf UKW, Sender "Antenne" ist gewählt. Dann Umschaten auf Raspi, alles prima. Raspi geht aus, Radio springt zurück auf UW, allerdings ist nun "Bayern 1" eingestellt. Der Sender "Antenne" ist allerdings auch verfügbar, nur eben nicht eingestellt.

Dieses Verhalten tritt auch auf, nachdem man das Auto verlassen hat, der Raspi ausgegangen ist (also längere Zeit Wagen abgestellt) und man wieder einsteigt und das Radio angeht. Meistens ist der RasPi dann noch nicht gebootet, das Radio hat keinen Wechsler und geht in den UKW Modus. Dort gibt es dann einen willkürlichen Radiosender, aber nicht den Sender, den man vorher aktiv hatte. Bei mir ist immer der Sender der Stationstaste 6 an, wenn der RasPi wie oben beschrieben neu startet, ist das dann nicht mehr der Fall.

Ist das ein Bug? Mache ich etwas falsch?


Viele Grüße

cgr

Drucke diesen Beitrag

Lightbulb Eine kleines LogFile 101 - Anfang mit Fragen ;-)
Geschrieben von: cgr - 16.07.2017, 13:16 - Forum: IBusCommunicator - Allgemein - Antworten (7)

Moin zusammen, 

da ich immer wieder wie ein "Ochs vorm Scheunentor" stehe, wenn es um das Thema Log-Files geht, anbei mal der Versuch, einen kleinen Guide entstehen zu lassen. 


Alos, im Prinzip gibt es drei Stellen im RasPi, an denen etwas zum Logging gemacht werden kann. 

1. My OSMC
       

2. IBUSCommunicator
   

3. Confluence Skin
   

Hierbei stellen sich mir immer wieder die Fragen:
- Welches Log nimmt man wofür?
- Welche Einstellungen braucht man?
- Wo sind die Logs dann gespeichert?
- Wie kriegt man die Logs am einfachsten exprotiert?


Leider habe ich mir bisher nicht wirklich Notizen gemacht, was man wie wofür loggen sollte, vielleicht können wir hierzu gemeinsam ein wenig Licht ins Dunkel bringen?

Ach ja, generell dann noch der hinweis: In den Logfiles scheint es ja unter Umständen (z.B. wenn man den IBUS loggt) persönliche Daten zu geben, also am besten immer checken, was Ihr wo mit wem tielt bzw. postet. Zum Beispiel gibt es im Datenlog teilweise Navi-Anweisungen, Positionen und Adressen sowie angerufenen oder Empfangene Tel.-Nummern, falls über BT telefoniert wird. 


Viele Grüße und danke für Eure Beiträge im voraus!

Ciao

cgr

Drucke diesen Beitrag

  No signal to nav screen
Geschrieben von: kukuryza - 05.07.2017, 20:18 - Forum: BMWRaspControl - english questions - Antworten (9)

[attachment=354]Hello guys,
Im using raspberry pi 3 with 4 pin jack plug to rca cable, I have already installed bmwraspcontrol v1.9 on the pi and it is operational, so i have tested this setup on a TV and it is outputing video, but when connected to the TV module im My car (e39) There is no video output. I have tried AV mode and all posible tv formats, still there is no signal from the pi.
White and blue TV module connectors are wired as per the schematic Found in the forum, video output from pi on pins 13 and 14 - white plug, pin 17 on blue plug with 100 ohm resistor connected to gpio 7 on the pi.
I have not found reseller? Still it should output video to the nav screen even without ibus connection, right?
Ive attached pictures on the blue and white tv module connectors and how i wired them.
Any guidance from your side is appreciated.



Angehängte Dateien Thumbnail(s)
       
Drucke diesen Beitrag

  Einbau im Wechslergehäuse beim 320D Touring
Geschrieben von: Glockenturm - 02.07.2017, 01:32 - Forum: BMW E46 - Keine Antworten

So,
da das System jetzt endlich fertig eingebaut ist, hier ein paar Fotos von meinem neuen CD Wechsler Big Grin
nochmal 1000 Dank an die Entwickler der Systems und an alle die mir mit vielen guten Ratschlägen zurseite standen.
[Bild: 19553855_1401779579906172_1208.jpg]

[Bild: 19554074_1401779649906165_5968.jpg]

[Bild: 19598583_1401779616572835_1862.jpg]

 Ich weis Das Ganze sieht etwas Kaotisch aus funktioniert jedoch Tadellos. Anstelle des Doppelseitigen Klebebandes habe ich zur Befestigung des Pi mittlerweile Klettverschlussband verwendet sodass ich den Pi einfach zum SD Kartenwechsel herausnehmen kann. Als Software kommt BMWRaspControl mit dem IbusComunicator von Harry zum Einsatz.

Drucke diesen Beitrag

  15min leitung bei der e39 limo
Geschrieben von: saggirus - 27.06.2017, 18:58 - Forum: Einbau - Antworten (5)

hat jemand ne ahnung wo ich die 15min leitung bei der limo finde?
evlt. am klimabedienteil aber am welchen kabel? 
am besten wäre es die leitung hinterm radio zu fidnen

Drucke diesen Beitrag

Question Stromversorgung über ein Relais mit GPIO Pin
Geschrieben von: Raceface - 26.06.2017, 11:26 - Forum: BMWRaspControl - Allgemein - Antworten (2)

Hallo zusammen, 

Mir ist aufgefallen, dass meine Batterie schnell leer gesaugt wird wenn an den USB Ports viele Sachen hängen.

Wäre es eventuell möglich über einen GPIO Pin ein Relais zu steuern welches beim deaktivieren der Zündung den da dran hängenden USB Verteiler abschaltet.
An dem USB Verteiler hängen eine 60GB SSD Festplatte, ein HDMI converter, Bluetooth, WLAN. 
Die Idee wäre, daß nur der Raspberry und das Interface mit Strom versorgt werden wenn mann das Fahrzeug abschließt. 
Wenn man die Zündung an macht schaltet der Raspberry dann den USB Verteiler über das Relais hinzu.
Dazu würde ich dann die 5v Leitung  vom Verteiler zum Raspberry kappen damit dieser nicht über den Raspberry weiterhin versorgt wird sondern nur über einen separaten Step Down converter über das Relais. 

Könnte man dies bei dem Addon hinzufügen!?

Vielen Dank im voraus!

Drucke diesen Beitrag