Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Behringer mit PI 3 steht nicht zur Auswahl
#11
kann man bestimmt der artikelbeschreibung entnehmen.
handsfree hat glaub schon jemand zum laufen gebracht. aus nem anderen forum.
IBusCommunicator:
Image <> Kodi Addon

[Bild: usersignaturpic-14941mspx.jpg]
Antworten
#12
Auch wenn es ein wenig am Thema vorbei ist: Ich hatte auch die Behringer verbaut und war mit dem Ergebnis nicht zufrieden. Ton war OK, Stabilität weniger. Nun habe ich eine HifiBerry light verbaut - bin mega zufrieden: Ton ist super, läuft absolut fehlerfrei!

Nur Mal so am Rande...
Antworten
#13
Anscheinend funktioniert mein Workaround auch nicht, deswegen habe ich den Beitrag gelöscht.

Bin immer noch auf der Suche nach einer Lösung. Ich denke es hängt an der Übergabe zwischen OS und Kodi...

Wenn ich

Code:
aplay -l

über das Terminal ausführe, dann bekomme ich alle möglichen Soundkarten aufgelistet. Unter anderem auch [CODEC Usb...], welche die Soundkarte darstellt, die ich angeschlossen habe.

Wenn ich jetzt über das Menü Einstellungen -> System -> Audio die Soundkarte auswählen möchte, wird diese nicht angezeigt.

Der Workaround, der hier angeboten wird, ist, dass man die Streaming to BT Variante wählt, welche auch funktioniert. Dennoch verstehe ich noch nicht ganz, warum die Soundkarte nicht im Menü auftaucht.
Antworten
#14
Also erstmal auch Respekt von meiner Seite, hab mir da auch mal den ganzen thread im e39 forum zu Gemüte geführt und auch einige raspi foren und tutorials angeschaut, da ich von raspi, linux, osmc, xbmc/kodi, phyton etc. bisher überhaupt keine Ahnung hatte.
Ich fahr auch erst seit 4 Monaten e39, hab aber noch nen e53.

Ich hab auf meiner Konfiguration (siehe Fusszeile) das Image v1.9 drauf.

Auch ich hab - auf den Tip eines e39-technisch sehr bewanderten kumpels -einen Hifiberry dac drangehängt statt einer usb-karte (die installationsanleitung auf der hifiberry-seite klingt ja sehr einfach, soll out-of-the-box unterstützt sein), ich hab allerdings keinen Ton, egal was ich tue.

@cbr:
Wie genau hast du das installiert, dass der Hifiberry bei dir läuft welches Image??
Oder wie hast Du das softwaremässig aufgebaut, welche versionen verwendet?

Hab schon mit dem Hifiberry Support getextet, (der is übrigens echt geil. Da bekommst auch Abends und am Weekend Antwort...), der weiss allerdings auch nicht weiter.
- Ich hab das overlay in der config.txt drin
- Ebenso den onboardsound in der config.txt deaktiviert.
- Der Overlay lässt sich im osmc auswählen -> OK
- Der Befehl $ aplay -l zeigt den hifiberry als einzige aktive Soundkarte an.

Gemäss hifiberry support müsste nun in dem settings-Menü die Alsa vom hifiberry zur soundausgabe zur verfügung stehen, was sie aber nicht tut, nur die 3 PI (analog, hdmi, beides) und dieStreaming gibt es. Aber auch bei der streaming alsa gibt es kein Ton.
Er meinte, da gibts ein Problem mit osmc oder kodi.

Hab dann über befehlszeile einige updates geladen die ich auf osmc.tv gefunden habe (bin wohl nicht der einzige wo das hifiberry, z.b. Nach update, nicht (mehr) läuft, einige haben es via update gelöst), hab mir damit dann aber das komplette bmwraspcontrol zerschossen und nachher ne normale osmc (oder kodi, kann da noch nicht so ganz unterscheiden was was ist) Version drauf gehabt.

Ich hab das 1.9image wieder neu aufgespielt, und bin wieder gleich weit.

Hat da einer von den Experten eine Idee wie ich die alsa vom hifiberry reinprogrammiert bekomme?
Oder welche updates/upgrades ich fahren darf (befehlszeile) oder ggf. Via osmc-menü), ohne dass das ganze bmwraspcontrol mit skin, ibus etc. flöten geht?

Oder gibt es ev. demnächst n neues image auf basis der aktuellsten osmc/kodi version?

Thanx........

Gruss aus der Schweiz.....
Raspberry PI3 - StromPi V2 - HifiBerry DAC+ RTC, Image V1.9
Versuchsfahrzeug: BMW E39 530d 2001 mit TV, MK3 und BM24. (Wird noch umgebaut auf DSP/BM54)
Zielfahrzeug: BMW X4 4.8is E53 mit TV, MK4 und DSP.
Antworten
#15
ein fast aktuelles image mit meinem addon gibt es hier: http://www.bmwraspcontrol.de/board/showt...hp?tid=438
hifi berry kann man dann über das osmc addon in den pi configs aktivieren.
IBusCommunicator:
Image <> Kodi Addon

[Bild: usersignaturpic-14941mspx.jpg]
Antworten


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste