Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Kleinere Probleme nach dem Einbau
#1
Hallo zusammen,

habe nun den Einbau und die Ersteinrichtung hinter mir. Generall läuft das System prima! Echt ein geniales Projekt und eine tolle Umsetzung!

Aktuell habe ich noch ein paar Kinderkrankheiten, die ich durchaus durch einige Addons selbst verursacht haben könnte...

Mein größtes Problem ist, dass der Pi nicht immer richtig startet.
Manchmal startet er Problemlos und kann bedient und benutzt werden, alles toll.
Manchmal schaltet der Wagen beim Start auf Radio um. Ich kann den CD-Wechsler per Mode-Knopf am Radio auswählen, es passiert jedoch nichts. Wenn ich dann den Resetknopf auf dem Modul von Harryberlin drücke, startet der Pi neu und alles ist gut.
Manchmal startet der Pi und Kodi ist zu sehen, dann schaltet das Bild auf BMW-OEM Ansicht um und ich komme meist nicht mehr an den Pi ran. Auch hier hilft der Resetknopf auf dem Modul von Harryberlin.
Gibt es da Lösungsansätze, oder liegt es ggf. an meinen Tests mit Addons, etc...

WLAN verbindet sich meist nicht. Habe hier was von der Tetheringfunktion gelesen und diese auch deaktiviert. Dennoch verbindet sich der Pi nicht automatisch mit einem WLAN. Gibt es da eine Lösung?

Heute habe ich Spotify installiert und wenn das WLAN funktioniert auch nutzen können. Echt eine feine Sache.

Dann hänge ich noch an der Einbindung von OBD per Edibaslib.

Wie kann das Skin modifiziert werden? Gibt es da Anleitungen zu? Hätte gerne noch ein paar Daten auf dem Homescreen...

Wann genau fährt der Pi herunter? Im Modul von Harryberlin kann eine Zeit gesetzt werden. Zählt diese ab Zündung aus, oder ab verriegeln des Fahrzeugs?
Antworten
#2
Hast du vllt. der wechsler noch verbaut?
Welches image nutzt du?
Teste die platine mal ohne raspberry, ob die wechsler emulation dann besser läuft.
die 3 läuft, wenn keine Aktivität mehr auf dem ibus ist.
1min vor ablauf wird dem addon ein befehl zum runterfahren geschickt.
nach der zeit, wird komplett alles abgeschalten, egal ob runtergefahren oder nicht.
wie man skins von kodi ändert gibt es einige sachen im web per google.

die zeit vom addon zählt glaub bei zv zu. da sollte der timer von kodi gestartet werden.
aber braucht man nicht unbedingt.
IBusCommunicator:
Image <> Kodi Addon

[Bild: usersignaturpic-14941mspx.jpg]
Antworten
#3
Nee der Wechsler liegt hier bei mir im Büro und wartet auf einen neunen Käufer...

Schätze mal es liegt eher doch an meinen Addons usw. Meine z.B. seitdem ich Samba installiert habe ist die Bootzeit deutlich angestiegen.

Nutze das Image von dir, was du in deinem Thread verlinkt hast.

Werde auch noch das Update am Arduino einspielen, da bin ich noch nicht zu gekommen, muss dafür das Gehäuse ein wenig bearbeiten...

Hast du Erfahrungen dazu, wie es ist, wenn man das System auf einem anderen Pi installiert und dann diese Installation im Auto nutzt?

So habe ich es bei der aktuellen Installation getan. Vielleicht installier ich noch mal direkt im Auto neu...Im Büro habe ich einen Pi 3 B und im Auto einen 3 B+
Antworten
#4
von ein pi zum anderen zu wechseln sollte kein unterschied machen.
IBusCommunicator:
Image <> Kodi Addon

[Bild: usersignaturpic-14941mspx.jpg]
Antworten
#5
Auch hier ein kleines Update.

Auch nach einer Neuinstallation hat sich das Startverhalten nicht gebessert und ich musste zu 50% immer die "Reset" Taste am Arduino drücken.

Seit einigen Wochen habe ich einen Schalter an die Stromversorgung des PIs angeschlossen. Ich fahre das System immer manuell herunter, warte ein wenig und Schalte dann den Strom ab. Bei der nächsten Fahrt starte ich das Auto und Schalte den Strom am Pi wieder ein, so funktioniert es zuverlässig, auch wenn es ein wenig aufwändiger ist.
Antworten


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste