Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Startschwierigkeiten Anbindung ans Auto/Abspielen von Musik/Netzwerk
#1
Hi zusammen,


hab jetzt mich am system versucht.
allerdings komm ich nicht weiter.  Huh Confused

mehrere huerden sind noch da ...


Netzwerk
da ich nicht im heimnetz bin, habe ich meinen raspberry mit direktem kabel verbunden.
allerdings bekomme ich den nicht auf statische ip umgestellt... nervt schon bisschen, denn nach jedem neustart bekommt er ne neue LLA adresse.


IBus
ueber hdmi kommt schon das bild zum bedienen, aber per bmw bedienung tut sich nix. (ich muss immer mit ner maus rumklicken)


resler interface geht wohl, nach der hilfe hier:
https://www.bmwraspcontrol.de/board/show...475&page=2


laut:
http://www.alextronic.de/bmw/projects_bm..._ibus.html


dort finde ich aber eine kleine abweichung:
<0F 04 68> <Tastencode> <XOR> (48 24 fuer eject)

IBUS: READ: F0 04 68 48 24 F0

Code:
der anfang der nachricht ist nicht gleich:

0F ist nicht F0

kann es sein dass deswegen kodi nix macht?!
es ist ein 4:3 bedienteil aus nem (vermutlich) e38


Code:
root@osmc:/home/osmc/ibustester_v0.6# python ibustester.py
IBUS: IBusTesterVersion: 0.6
IBUS: SerialModulVersion: 3.4
IBUS: SerialDevice: /dev/ttyUSB0
IBUS: Connecting
IBUS: Connected
IBUS: READ: F0 04 3B 49 01 87
IBUS: READ: F0 04 3B 49 81 07
IBUS: READ: F0 04 3B 49 01 87
IBUS: READ: F0 04 68 48 00 D4
IBUS: READ: F0 04 68 48 80 54
IBUS: READ: F0 04 68 48 00 D4
IBUS: READ: F0 04 68 48 80 54
IBUS: READ: F0 03 68 01 9A
IBUS: READ: F0 04 68 48 02 D6
IBUS: READ: F0 04 68 48 82 56
IBUS: READ: F0 04 68 48 02 D6
IBUS: READ: F0 04 68 48 82 56
IBUS: READ: F0 04 68 48 02 D6
IBUS: READ: F0 04 68 48 82 56
IBUS: READ: F0 03 68 01 9A

IBUS: READ: F0 04 68 48 24 F0



Musik
wenn ich ein usb stick ransteck kann ich musik hinzufuegen, aber es spielt maximal ne sekunde dann bleibt es stehen. aber die sekunde kann ich es auch hoeren ;-)
sound geht wohl... aber das abspielen nicht.

ich habe es auch ueber die webseite versucht, dann zeigt die webseite auch kurz an dass es spielt, tut es aber auch nur fuer ne sekunde.


raspberry pi 3B+
behrringer soundcard
resler ibus modul (Resler USB IBUS-Interface V6 incl. cable)

dieses image habe ich installiert:
Code:
Für Resler Interface:
Download V8.7 USB Testversion (OSMC for Pi2, 3, 3B+): https://goo.gl/4sH5VD (4GB Card)
Antworten
#2
Lade dir bitte mal das image hier:
https://drive.google.com/open?id=11YsfUq...hij1lM3LMe

es ist libreelec für rasp4, läuft aber auch auf dem 3er
die addon settings musst du jedoch für usb wieder umstellen. am einfachsten auf standard und mir ok verlassen.
dann sollte das ganze im auto laufen.
die audio ausgabe müsste auch in kodi wieder auf analog gestellt werden.

kann leider nicht immer für jede konstellation neue images erstellen.

mit tail -f "pfad_zum_log-file" kannst du verfolgen was in kodi passiert.
mein router vergibt meinen rasp eigentlich immer die gleiche ip, sofern es der gleiche rasp ist.
IBusCommunicator:
Image <> Kodi Addon

[Bild: usersignaturpic-14941mspx.jpg]
Antworten
#3
tail kenn ich ;-)

hoffentlich finde ich die kodi log datei.

da ich mein raspberry mit meinem pc direkt verbinde, habe ich keinen router hier.
deswegen wollte ich ja statisch vergeben.
aber das geht wohl auch mit dem nicht. (hatte noch eine einstellung gefunden, aber die ist es wohl auch nicht avahi zero conf)



was ist denn das passwort fuer das image? (wie ich das passwort aendere hab ich gefunden, aber welcher benutzername ist es denn?)
osmc:osmc
osmc:password

geht beides nicht, konnte damit auch nicht das ibustest script ausfuehren...


bedienung hatte ich umgestellt auf usb. auch einmal neugestartet, aber leider nix.
knopfdruecke usw machen nix.
logdatei konnte ich nicht holen weil ich nicht das richtige passwort habe.


koenntest du das noch mitgeben?
DANKE!!!  Cool


musik abspielen, ist immer noch nach ner sekunde wieder auf stopp.
diesmal aber ohne sound. die soundkarte wird nicht angezeigt.
Antworten
#4
wie gesagt es ist libreelec
http://letmegooglethat.com/?q=ssh+passwort+libreelec

musik stoppt, weil keine ibus verbindung besteht.

also gut, ich erstelle ein neuen osmc image kam eh letztens ein neues release.
IBusCommunicator:
Image <> Kodi Addon

[Bild: usersignaturpic-14941mspx.jpg]
Antworten
#5
ah.

ich hab nicht verstanden, dass das passwort sein soll.
sorry.


Code:
systemctl stop kodi.service

damit konnte ich dann auch kodi zum stoppen bringen und auch den ibustester.py starten.

hier kommen dann auch wieder daten.



starte ich den service wieder, kommt folgendes im kodilog (tail -F /storage/.kodi/temp/kodi.log)

Code:
2019-04-11 17:45:20.782 T:2573198192  NOTICE: IBUSCOMMUNICATOR: / PLAYERID: 0
2019-04-11 17:45:20.867 T:2573198192  NOTICE: IBUSCOMMUNICATOR: - KODI: PAUSE
2019-04-11 17:45:30.356 T:2794779504   ERROR: ## LibreELEC Addon ## oe::load_url(http://releases.libreelec.tv/releases.json) ## ERROR: (URLError(gaierror(-2, 'Name or service not known'),))
2019-04-11 17:45:30.357 T:2794779504   ERROR: Traceback (most recent call last):
                                              File "/var/lib/jenkins/LE/build2/workspace/RPi4/build.LibreELEC-RPi4.arm-9.1.502/LibreELEC-settings-a799a10652567cfd327fd588cf0e180d9962cf61/.install_pkg/usr/share/kodi/addons/service.libreelec.settings/oe.py", line 272, in load_url
                                              File "/usr/lib/python2.7/urllib2.py", line 154, in urlopen
                                              File "/usr/lib/python2.7/urllib2.py", line 429, in open
                                              File "/usr/lib/python2.7/urllib2.py", line 447, in _open
                                              File "/usr/lib/python2.7/urllib2.py", line 407, in _call_chain
                                              File "/usr/lib/python2.7/urllib2.py", line 1228, in http_open
                                              File "/usr/lib/python2.7/urllib2.py", line 1198, in do_open
                                            URLError: <urlopen error [Errno -2] Name or service not known>

sonst aber nix.
dass hier ruhe ist, heisst wohl dass kodi wohl nicht den ibus abhoeren kann. (wie du gesagt hast)

warum denkt kodi dass es nichts abspielen soll, wenn keiner zuhoert?


bei mir haengt nicht das ganze auto dran...
nur das bedienteil. (noch) denn der kram liegt hier bei mir auf dem tisch... am auto schrauben mach ich erst wenn es mal einigermassen zuckt.


sorry wenn ich so doofe fragen stelle... vermutlich kommen da auch meine "startschwierigkeiten" her.
Antworten
#6
weil das addon nur die wiedergabe startet, wenn es das radio sagt.
anderfalls wird immer wieder gestoppt. soll ja nicht im hintergrund weiterlaufen, wenn man das auto verlässt.
ohne zu wissen was du auf dem tisch "hast" bzw. "nicht hast", kann es nicht immer funktionieren.
IBusCommunicator:
Image <> Kodi Addon

[Bild: usersignaturpic-14941mspx.jpg]
Antworten
#7
(27.11.2019, 17:10)harryberlin schrieb: weil das addon nur die wiedergabe startet, wenn es das radio sagt.

dann hab ich vielleicht zu viel vor...

ich weiss dass beim zemex zb das ausschalten vom radio bemerkt wird um die stelle zu speichern. das geht wohl ziemlich flott. (max 1-2 sec)


dann werd ich wohl mal die gespraeche mitlauschen, um dann das addon fuer mich anzupassen.


Code:
IBUS: READ: F0 03 68 01 9A

diese nachricht wird alle 10 sec vom "tasten bordmonitor" geschickt. (info hab ich daher: http://www.alextronic.de/bmw/projects_bm..._ibus.html)

daraus entnehme ich dass es vom "tasten bordmonitor" an das radio gehen soll.

als welcher teilnehmer ist denn kodi drin? bzw auf was hoert kodi?

gern les ich mich dazu ein! wusste nur noch nicht wo ich starten soll.
ich wollte wenigstens eine gute grundlage haben... damit ich nicht total im dunkel stocher.
Antworten
#8
ich verstehe nicht was dein vorhaben ist.
das mit dem "0F" auf alextronic ist ein fehler.
für letzte wiedergabe position ist das addon relaiblresdume zuständig.
ibuscommunicator (entsprechend kodi) emuliert einen cd-wechsler in audio-mode CD
zemex und cd emulation zusammen funktioniert nicht.
was willst du denn anpassen?
IBusCommunicator:
Image <> Kodi Addon

[Bild: usersignaturpic-14941mspx.jpg]
Antworten
#9
grobes ziel ist ein funktionierenden player im auto zu haben, der mir die moeglichkeiten offen laesst bisschen rumzuspielen.
- obd
- codieren
- navi
- ein traum war schon immer so ein skin zu aendern, zb LCARS like


software engineer nenn ich mich derzeit, allerdings bin ich vor lauter regularien so raus, dass ich gern mal wieder was programmieren moechte.


ich hab zwei autochen denen ich das gern verpassen wuerde. (750i bj 98)
und anfangen moechte ich beim 525iT Bj 2001


der 5er hat business drin... hab dem ein zemex verpasst. aber happy bin ich damit nicht.


da ich noch einen 4:3 bedienteil und ein raspberry 3B+ rumfliegen hatte... hab ich mir mal brocken bestellt:
- behringer soundkarte
- resler interface
- 3.5 zoll touch fuer den raspberry (der ist aber noch nicht da)

quasi wird dann im auto kein radio mehr drin sein.
wechsler hab ich auch keinen
navi auch nicht
von daher wird der raspberry auch spaeter nicht viele kommunikationspartner haben (zumindest bezogen auf die audio ausgabe)

und da ich bei dem wetter nicht wirklich draussen schrauben moechte, hab ich mir das hier hingelegt.
leider hab ich hier kein internet am raspberry. nur direkte verbindung zum rechner. (winscp..)


gibt das ein besseren blick auf meinen plan?  Cool Big Grin
Antworten
#10
wenn du nur den monitor auf dem tisch hast, dann musst du den bei laune halten.
der muss auch wissen, wann die zündung an ist. sonst sendet der keine telegramme.

im addon gibts auch die audiomode ALWAYS, die ist da eher angebracht.
navi auf linux gibts eher schlechte lösungen.

internet kann man auch per lan kabel zum rasp freigeben. bridge oder so nennt sich das.

hier ist jetzt ein neues image: https://www.bmwraspcontrol.de/board/show...hp?tid=438
IBusCommunicator:
Image <> Kodi Addon

[Bild: usersignaturpic-14941mspx.jpg]
Antworten


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste