Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
RTC vs AVR Shield Einstellung
#1
Hi,

soweit ich verstanden habe, hat der AVR-Shield ja eine RTC mit drin. Richtig?
Wenn ja wie ist da die Bootreihenfolge geloest?

Ich habe mir eine RTC (einzel) geholt.

Soweit funktioniert das ganze auch. Allerdings ist jetzt beim booten eine Wartezeit drin, wenn der kein Netzwerk hat.

Code:
/lib/systemd/system/connman-wait-for-network.service

darin hab ich das warten von 60 runtergedreht und er wartet nicht mehr so lange. Quasi geht das, aber klingt nach gefummel... 


Um die Reihenfolge/Werte usw einzustellen, wuerd ich im OSMC schauen, mich hat nur interessiert was die Erfahrungswerte fuer die andere Implementierung sind.
ntp abstellen, spaeter laden, oder so...!?

Denn im Auto hab ich kein Netz. Und ich wollte trotzdem die korrekte Uhrzeit haben ;-)

edit: habe das neueste image genommen "V2020.10-1 USB [Testversion] (OSMC for Pi2, 3, 3B+):"
Zitieren
#2
ich habe den Count in dem Script jetzt auf 2 runtergestellt.
Ist jetzt in Ordnung fuer mich.

damit kann ich leben  Cool
Zitieren
#3
nein, da ist keine rtc drauf. die Uhrzeit kommt vom fahrzeug.
IBusCommunicator:
Image <> Kodi Addon

[Bild: usersignaturpic-14941mspx.jpg]
Zitieren
#4
ah ok.

danke!

naja so wie es jetzt ist... gehts ja ;-)



wenn es jemanden interessiert, hier mal was ich alles gedreht hab, damit es soweit funktioniert.


ebay rtc modul

hinzufuegen zu /boot/config.txt:
Code:
dtparam=i2c_arm=on
dtoverlay=i2c-rtc,ds3231

hinzufuegen zu /etc/modules
Code:
i2c-dev

editiere /lib/udev/hwclock-set
Code:
if [ -e /run/systemd/system ] ; then
    exit 0
fi

Replace With

#if [ -e /run/systemd/system ] ; then
#    exit 0
#fi

erzeuge /lib/systemd/system/rtc.service
mit inhalt:
Code:
[Unit]
Description = get systemdate from rtc
After = mediacenter.service
[Service]
Type = simple
ExecStart = /home/osmc/scripts/bootrtc.sh
[Install]
WantedBy = multi-user.target

hier drauf achten dass die pfade zusammen passen, und auch dass das script ausfuehrbar ist.

erzeuge /home/osmc/scripts/bootrtc.sh
mit inhalt:
Code:
#!/bin/bash

LOG=/home/osmc/rtc.log

# clear logfile
cat /dev/null > $LOG

# small log helper
mlog() {
  echo -e "$1" | tee -a $LOG
}

mlog "try to set localtime via rtc"
mydate=`date`
mlog "$mydate"

while ! hwclock -s ;  do
    mlog "Failed to sync RTC to local time."
done

mydate=`date`
mlog "$mydate"

mlog "Successfully synced RTC to local time"

exit


editiere /lib/systemd/system/connman-wait-for-network.service (er wartet sonst 60 mal  auf den ntp server zugriff und gibt dann auf, ohne netzwerk kann er auch gleich aufgeben)
ersetze "60" mit "2"



dann den ganzen dienst gedoens anschalten bzw abschalten:
Code:
# die fake uhr brauchen wir nicht mehr
update-rc.d -f fake-hwclock remove

# i2c tools die fuer die kommunikation mit der uhr gebraucht werden
apt-get install python-smbus i2c-tools

# die daten neu laden fuer den service gedoens
systemctl daemon-reload
# den service fuer die uhr anschalten
systemctl enable rtc.service
# den service starten
systemctl start rtc.service
# ob man das braucht weiss ich nicht mehr... aber ich habe es abgeschaltet um zu verhindern, dass beim starten die zeit vom netz gezogen wird (meistens im auto ja nicht da)
systemctl disable http-time.service

im anhang ein bild wie das modul auf dem raspi sitzt.


Angehängte Dateien Thumbnail(s)
   
Zitieren
#5
d.h. bei dir scheint es nicht zu gehen, mit der zeit vom fahrzeug.
was ist bei dir anders? IKE LOW oder auf MID codiert?
IBusCommunicator:
Image <> Kodi Addon

[Bild: usersignaturpic-14941mspx.jpg]
Zitieren
#6
ich glaub ich hab buchhalter ausstattung ;-)
im kombi zeigt er temp und verbrauch usw an... viel mehr nicht.

business radio mit kassette war vorher drin
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 2 Gast/Gäste